You are viewing a single thread.
View all comments I propose a new, more threatening kind of control flow.
do {
/* something */
} or else {
/* you don't want to find out */
}
8 points
5 points
23 points
10 points
6 points
60 points
Some C++ style guides suggest the following naming convention for functions that crash on any error
OpenFileOrDie()
1 point
3 points
4 points
10 points
Personally, I like to call catched exception variables up
, so for a rethrow I can throw up;
.
2 points
4 points
27 points
PHP has the always wonderful (and perfectly functional) syntax of
logUserIn() or die();
42 points